rejetto forum

when i am uploading file, hfs is not responding

0 Members and 1 Guest are viewing this topic.

Offline bhj1234

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
hello:
         when i log in the hfs, and upload a file(size is 100M), in this time, the hfs server is not responding, other client cannot access the url。
         when upload finish, hfs is running.

        i don't known what reason , please help me! thank you very much.


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
I don't quite get your issue.

Is your issues tryig to uplad the 100MB file or downlaod it form hfs?

first, i would recomend you increas your "time out" to quarantee a descent conection as it might be timeing out due to too much time passing...
in hfs > menu > Limits > Conection inactivity timeout > (pop up box {default 60 seconds])
you would probaly want to put 3-5 minutes (just to try change 60 to 180) and try to uplad the file.

(I doubt it could be, but you mgiht not have enouth disk space) just to be sure double check you settings:
hfs >menu > limits > minuminum disk space  (this should be blank by default, but may need "1 MB" defining meaning that hfs won't take and except the file if your hd will be full and out of space....

Other wise, i would recomend you redownlaod HFS and put in it a new folder somewhere else and test that version witht he same thing that your previous hfs was unable to do (are there any changes/issue?)

Hope this helps :)
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline bhj1234

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
    Thank you for your reply, perhaps my description of the problem is not too clear.

    I'm using hfs 2.3 version, as long as there is a file upload operation, during this time, hfs will lose response, click on the button hfs no response, the client can not log in through, when the upload is finished, hfs recovery response, the client is also normal landing.

    This problem only upload, download no problem.


    I hope to get your help again,thank you.


Offline bhj1234

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
I probably know the reason, my real directory using a NAS storage, after I replaced the local hard drive, hfs is running normal, I do not know if it is stored on the NAS access problems.


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
sounds like you need to map a network drive as a loacl user disk drive

----
cmd:
net use z: \\%path to your nas%\hfs folder shared
-----

other wise see this link depending on os:
http://wdc.custhelp.com/app/answers/detail/a_id/2676/~/mapping-a-personal-cloud-drive-or-wd-nas-drive-on-a-windows-pc

Mapping a Network Drive

Method or Tool Used
Instructions
WD Discovery   Click Here for Instructions
(instructions will appear below this table)
Windows 8   Click Here for Instructions
(instructions will appear below this table)
Windows 7 & Vista   Click Here for Instructions
(instructions will appear below this table)
Windows XP   Click Here for Instructions
(instructions will appear below this table)
WD Link   Click Here for Instructions
(instructions will appear below this table)

Please select a method to map a network drive from the table above to display that method's instructions.
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
then add the upload folder as a real folder to drive z:\

if you are still experiencing issues it is windows side permission and the folder on the nas needs to have read write permision to the folowing users and groups: (everyone / guest / AYNOMOUS LOGON / %your current user% / System / administrators / users )

http://www.wikihow.com/Change-File-Permissions-on-Windows-7

or (depending your nas server(what kind it is and how it is setup) you might need to change access right permissions: read/write on the NAS via the NAS configuration or by login into its web console
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline bhj1234

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
hello,thanks for your reply,I follow your argument, cmd: net use z: \ \% path to your nas% \ hfs folder shared, then create real directory, but the problem still exists。Upload ultimately be successful, so access should not be a problem


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
I would have you check the windows side permission on the folder you are sharing so you can guarantee you have read/write capabilities... (are you able to right click in the "z" mapped drive and create documents? if yes than permision should be fine, if no, see previous post) -- I don't think it is as you claim you have access rights...

Other wise the last option you could do is have a local folder such as "C:webroot\%hfs shared folder$"
and sycn that folder with you nas using programs or similar programs like Qsync or windows sync...

http://www.qnap.com/useng/index.php?sn=8976

so when a file is uploaded to ("C:webroot\%hfs shared folder$") it will auto sync to the mapped "Z" drive or your *\\%path to your nas%\hfs folder shared)

i don't think i will be able to help you any farther than this, good luck and have fun! :)

--------------
Rejjeto might have a fix for this as it sounds like a bug in the script for upload in which:

upload files fails to put/write to the unc shared path/directory...
--------------
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 729
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
I may be wrong, but this can be related to your antivirus (the antivirus that you are running along with HFS, in the server). May be your antivirus is scanning your uploaded file, so it hangs the server by a few seconds. You may try to temporarily disable your antivirus in the server and repeat all the operation to see if it happens again.
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
» Currently taking a break, until HFS v2.4 get his stable version.