Author Topic: I can't upload a file bigger than 2097152000  (Read 1630 times)

0 Members and 1 Guest are viewing this topic.

Offline giggy

  • Occasional poster
  • *
  • Posts: 23
    • View Profile
I can't upload a file bigger than 2097152000
« on: February 23, 2013, 10:12:58 PM »
File size error.
File: MVI_1239.MOV, size: 4292768864, max file size: 2097152000

I configured to upload a file bigger than 50 gig in the admin panel but I still get this error msg.
What should I do?

Thanks.

Offline raybob

  • Moderator
  • Tireless poster
  • *****
  • Posts: 453
    • View Profile
    • FileSplat.com
Re: I can't upload a file bigger than 2097152000
« Reply #1 on: February 24, 2013, 04:56:27 AM »
I have it programmed (implicitly) so that it won't let you select a max file size bigger than 2 GB.

The reason for that is that most browsers literally don't themselves support uploading files bigger than that.

Offline giggy

  • Occasional poster
  • *
  • Posts: 23
    • View Profile
Re: I can't upload a file bigger than 2097152000
« Reply #2 on: February 24, 2013, 09:11:16 AM »
I appreciate your well thought out consideration on it.

But I tried with files bigger than 4 gig with hfs and it was working fine.
And nowadays many VOD files are being uploaded and they are getting bigger and bigger.
I really hope you reprogram it to at least 10 gig per file size or no limitation at all in file size and let the browse decide.

Thank you.
« Last Edit: February 24, 2013, 10:28:14 AM by giggy »

Offline raybob

  • Moderator
  • Tireless poster
  • *****
  • Posts: 453
    • View Profile
    • FileSplat.com
Re: I can't upload a file bigger than 2097152000
« Reply #3 on: February 24, 2013, 08:46:32 PM »
I'm sorry, it's been so long since I've worked on FHFS I forgot what I have and haven't accomplished yet...

I looked at the admin console and it looks like I never actually ended up making it so the admin can control the max file size.

As of 2.0.5 it's set to allow a max of 2GB, or less if the max account size is smaller.  But there's no way to explicitly set the main file size.

The entry you see in the admin panel is for setting the maximum ACCOUNT size, aka the maximum space any user's account or all of their files collectively can take up.

I actually have an overhaul of the admin console planned for v2.2 (whenever that occurs).

As of now, the solution for you is to open uploader.js, and replace this line:

Code: [Select]
max_file_size: '{.if|{.and|{.^maxsizeMB.}|{.<|{.^maxsizeMB.}|2000.}.}|{.^maxsizeMB.}|2000.}mb',
with whatever you want the max file size to be, e.g. something like

Code: [Select]
max_file_size: '8000mb',
Make sure you include the colon, the comma, the mb, etc exactly as above.... I hope that fixes your problem :)
« Last Edit: February 24, 2013, 08:55:08 PM by raybob »