Author Topic: I can't get port 8080 to work out side my internet , is it a possible bug ?  (Read 86228 times)

0 Members and 1 Guest are viewing this topic.

Offline yamanassaf

  • Occasional poster
  • *
  • Posts: 4
    • View Profile
installed the program, I already have another server (iis) using port 80 which host my website, so I need to use a different port than port 80. port 8080 seems to work fine locally however when I click on self test or try to access the site out side my internet,connection fails. I removed my router, disabled all firewall and still no luck. tried different ports and no luck,  I spent hours reading numerous thread and still no luck, uninstalled and reinstalled the program, tried to restore it and that didn't help either.  port forwarding didn't help either.  I have tried everything for no avail. finally I changed the port on iis server to 8080, and changed hfs to port 80 and this seems to fix the problem. hfs doesn't seem to work on any other port other than port 80 (except internally within your internet connection) so I conclude it is not a port forwarding or a firewall issue but it is a bug, I can't think of any other explanation, I did not sleep, I stayed up all night and was not able to fix this issue, I would appreciate if someone could help me out.   I can not run my website on port 8080 because visitors would need to type the port number after the url to access my website, and I don't want to do that.  is there a way to make hfs work on port 8080 outside my internet connection?

Offline Bigjake52

  • Occasional poster
  • *
  • Posts: 2
    • View Profile
Have you checked your router settings to make shure 8080 is forwared, and not to another system perhaps? its best to run your server with a static IP not in the range of your regular IPS
like my server is 192.168.1.34 and my computers are in the 100"s so it will not interfere with my normal serving,


Offline FRENCH CAN CAN

  • Tireless poster
  • ****
  • Posts: 681
    • View Profile
If you use the self test is perhaps a likely the same bug, I checked it with port 8080 open and HFS works, the self test says is wrong but it works, try connecting from a proxy server type: http://kproxy.com/ and see if port 8080 works with HFS. Hello, French.  8)
« Last Edit: June 25, 2011, 11:12:15 PM by FRENCH CAN CAN »

Offline yamanassaf

  • Occasional poster
  • *
  • Posts: 4
    • View Profile
it's correctly forwarded to the correct machine, and I do run it on static ip, as I said I run my website on this computer, I have no known issues with iis server but this one is a nightmare. 
Have you checked your router settings to make shure 8080 is forwared, and not to another system perhaps? its best to run your server with a static IP not in the range of your regular IPS
like my server is 192.168.1.34 and my computers are in the 100"s so it will not interfere with my normal serving,



Offline yamanassaf

  • Occasional poster
  • *
  • Posts: 4
    • View Profile
it works on port 8080 from within my internet connection but when I try it on a proxy server such as http://www.hidemyass.com, I get a connection error that it can not connect to the specified port, again when  I try to connect from somewhere else outside my internet I get the same connection error.   I think the self test is working fine, no bug there.
did you try to connect with port 8080 on proxy server or from outside your internet (maybe at work)?
I am just wondering whether any one was able to connect to other ports than port 80 from outside their internet ! I doubt it's a bug

If you use the self test is perhaps a likely the same bug, I checked it with port 8080 open and HFS works, the self test says is wrong but it works, try connecting from a proxy server type: http://kproxy.com/ and see if port 8080 works with HFS. Hello, French.  8)

Offline FRENCH CAN CAN

  • Tireless poster
  • ****
  • Posts: 681
    • View Profile
Mmmm! Try this site to verify if indeed the port 8080 is open.

Link:

http://www.yougetsignal.com/tools/open-ports/

Offline r][m

  • Tireless poster
  • ****
  • Posts: 347
    • View Profile
proxy server such as http://www.hidemyass.com,
I just tried "hidemyass" and I can't connect to my server through them. They have a problem.
I can through http://kproxy.com/
It appears HFS self test isn't working here.  Use http://canyouseeme.org/ to check your port,
it works, just used it.
http://www.yougetsignal.com/tools/open-ports/ as posted by French works great too.
« Last Edit: June 26, 2011, 02:39:48 PM by r][m »

Offline yamanassaf

  • Occasional poster
  • *
  • Posts: 4
    • View Profile
I think you are right, the self test is not working properly, thank you all for helping me

I just tried "hidemyass" and I can't connect to my server through them. They have a problem.
I can through http://kproxy.com/
It appears HFS self test isn't working here.  Use http://canyouseeme.org/ to check your port,
it works, just used it.
http://www.yougetsignal.com/tools/open-ports/ as posted by French works great too.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
so the self-test stopped working on other ports?
sorry for the problem.
such problems are almost never in HFS itself but in the web-service it uses for port checking.
I cannot even test it now because i'm in office. I'll do asap.

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
(as it might not be the "hfs self test script)
Just double check:
Sounds like you need to setup some basic networking to get things running!

-----------------

you will need to double check 3 things to make it use able over the web:

1. Windows side: ( i will assume you are using windows 7 ) at least i will post info link to windows 7...(most likely useable for all windows side os...)

You might need to set the "hfs machine" to a static ip address (this way when you open ports or use web traffice it has a "definite path"

windwos comand prompt:
cmd > "ipconfig /all"(<=command) has all the network info you need:
http://windows.microsoft.com/en-us/windows/change-tcp-ip-settings#1TC=windows-7

ip address is the machine address
subnet depends on your network most likely "255.255.255.0"
gateway is your router's ip adress most likely "192.168.1.1"

you will need to allow hfs thorugh your firewall
http://www.sevenforums.com/tutorials/542-windows-firewall-add-remove-exception.html

2. Router/(intranet) network side
you router will need the port you chose in hfs (say you set the port to 8080 go to you router- in a web browser typ in the ip address of your gateway)

enable "port forward" to your machine and the router to the same port ie port (starting port) 8080 to port (ending port) 8080
http://www.wikihow.com/Set-Up-Port-Forwarding-on-a-Router

*note some router don't allow you to use your "public" ip address to view inside, so while your at home your webpage is accessible via the ip address you set to the machine earlier

(if your router supports it you can have it memorize you "hfs" machine "network address (known as a mac address) and assign it a specific ip address so it will always be "192.168.1.x" x being the number you set i chose 254 as it is the last number dhcp will use...

3. Internet/Modem side
go to http://www.ipchicken.com/
This is your public ip adress so when you are not at home you will go to this ip adress (xxx.xxx.xxx.xxx) what is shown at the website above one of many website that can tell you your public ip adress...

You should now have hfs viewable form the outside world via:
http://xxx.xxx.xxx.xxx:8080
(xxx your public ip address)

Since modems can be dynamic ip adress you can opt to get a "dns name so instead of typing xxx.xxx.xxx.xxx you type a predefined word such as mywebsite.(frre public domain).org

DNS free domains names:
either by adding it into the router or have it client side, or even pre-setup in a dns online website..

I'm having good luck with http://freedns.afraid.org/ using mooo.com as my public domain...(website presetup)
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline LeoNeeson

  • Tireless poster
  • ****
  • Posts: 586
  • Solitario...
    • View Profile
    • twitter.com/LeoNeeson
(as it might not be the "hfs self test script)
Just double check:
Woah! :o This thread it's two years old!!, and yamanassaf's last visit was: 26-06-2011, 22:03:06. He probably won't care about this anymore. I mean, it's great to help people, and giving solutions, but....... ::)

Thanks anyway...... :P
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
• I'm open to help and share any file you may need (just ask me) ;)

Follow members gave a thank to your post:


Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Woah! :o This thread it's two years old!!, and yamanassaf's last visit was: 26-06-2011, 22:03:06. He probably won't care about this anymore. I mean, it's great to help people, and giving solutions, but....... ::)

Thanks anyway...... :P


whoops my bad, i'll have to remember to check dates, as i travel back in the post posts and see "new" and think it is new...lolz :)
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Follow members gave a thank to your post:


Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
eheheh

Offline jetbreaker

  • Occasional poster
  • *
  • Posts: 1
    • View Profile
Hey Guys,

I've been following this guide http://www.instructables.com/id/How-to-Host-Your-Own-Cloud-v20/

and I'm stuck in Step 4 currently. I have a Linksys E2500 router and I tried using this http://www.yougetsignal.com/tools/open-ports/

But it seems that all my ports are closed and I've tried a million different things and nothing. I can't externally access my publicIP:8080

I don't know what else I can try at this point.

Any help will be very much appreciated,

Thanks!

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Started a New topic for this:
http://www.rejetto.com/forum/hfs-~-http-file-server/how-to-host-your-own-cloud-v2-0/

-------------------------------
Hey Guys,

I've been following this guide http://www.instructables.com/id/How-to-Host-Your-Own-Cloud-v20/

and I'm stuck in Step 4 currently. I have a Linksys E2500 router and I tried using this http://www.yougetsignal.com/tools/open-ports/

But it seems that all my ports are closed and I've tried a million different things and nothing. I can't externally access my publicIP:8080

I don't know what else I can try at this point.

Any help will be very much appreciated,

Thanks!

-----------

review step 3 and make sure you reread all and configure it all...
http://www.instructables.com/id/How-to-Host-Your-Own-Cloud-v20/step3/Configure-Apache2/

dopuble check you port configuration with netstat:
http://manpages.ubuntu.com/manpages/precise/man8/netstat.8.html

Restart to guarantee configs saved and reloaded!
« Last Edit: August 19, 2014, 03:51:18 PM by bmartino1 »
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1