Author Topic: unwanted port change  (Read 1437 times)

0 Members and 1 Guest are viewing this topic.

Offline chthonic

  • Tireless poster
  • ****
  • Posts: 121
  • I own the copyright to this image... "Back Off!"
    • View Profile
unwanted port change
« on: January 26, 2010, 08:06:19 PM »
this applies to previous versions as well.... for some strange reason... the HTTP port keeps reverting to my Stunnel port instead of port 80.... this is very annoying... no matter how my times I save the setting it keeps changing back.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: unwanted port change
« Reply #1 on: January 26, 2010, 08:28:44 PM »
1. please paste here the content of your
menu > debug > show customized options

2. WHEN does it happen?

Offline chthonic

  • Tireless poster
  • ****
  • Posts: 121
  • I own the copyright to this image... "Back Off!"
    • View Profile
Re: unwanted port change
« Reply #2 on: January 26, 2010, 08:37:39 PM »
1. please paste here the content of your
menu > debug > show customized options

2. WHEN does it happen?

usually after a reboot

but there is no reason why it should jump to the stunnel port (44300)... the router passes the traffic from that port to port 80 internally.. but that port is used for other things.. thus my confusion?

[debug custom options]
easy=no
# default: yes

port=80
# default:

files-box-ratio=0.286679536679537
# default: 0

log-date=yes
# default: no

tpl-file=I:\chthonia virtual FTP\myTerayon v1.3.3.tpl
# default:

custom-ip=chthonia.myftp.org
# default:

dynamic-dns-updater=
# default:

dynamic-dns-host=chthonia.myftp.org
# default:

start-minimized=yes
# default: no

auto-save-vfs=yes
# default: no

folders-before=no
# default: yes

prevent-leeching=no
# default: yes

tray-icon-for-each-download=no
# default: yes

recursive-listing=no
# default: yes

list-protected-items=yes
# default: no

browse-localhost=no
# default: yes

last-dialog-folder=G:\RECIPES\Text_Recipes\
# default: I:\chthonia virtual FTP

last-update-check=40204.5728871875
# default: 0

tray-shows=ips
# default: downloads

last-file-open=I:\chthonia virtual FTP\VFSdata\chthoniaVFS.vfs
# default:

encode-non-ascii=no
# default: yes

address2name=
# default:

recent-files=I:\chthonia virtual FTP\VFSdata\chthoniaVFS.vfs
# default:

trusted-files=I:\chthonia virtual FTP\VFSdata\chthoniaVFS.vfs
# default:

tray-instead-of-quit=yes
# default: no

last-external-address=71.205.110.98
# default:

out-total=12980298405
# default: 0

in-total=14491155
# default: 0

hits-total=27992
# default: 0

downloads-total=7962
# default: 0

connections-columns=IP address;120|File;180|Status;180|Speed;60|Time left;55|Progress;442|
# default: IP address;120|File;180|Status;180|Speed;60|Time left;55|Progress;70|

ip-services=http://www.dovedove.it/hfs/ip.php|;http://www.checkip.org|color=green>;http://www.whatismyip.org/|;http://www.melauto.it/public/rejetto/ip.php|;http://checkip.dyndns.org|:;http://2ip.ru|#0033FF">;http://www.canyouseeme.org|td><b>
# default:

ip-services-time=40204.5828023727
# default: 0

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: unwanted port change
« Reply #3 on: January 27, 2010, 11:12:39 AM »
what if you just quit and restart HFS ?

Offline chthonic

  • Tireless poster
  • ****
  • Posts: 121
  • I own the copyright to this image... "Back Off!"
    • View Profile
Re: unwanted port change
« Reply #4 on: January 27, 2010, 03:34:30 PM »
it acts fine once the number is changed back to 80

the oddity only seems to show up on reboot.. and this happened in the previous build as well.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: unwanted port change
« Reply #5 on: January 27, 2010, 06:04:37 PM »
please, try this
- menu > save options > to file
- quit
- reboot
- don't start HFS, first open file hfs.ini (in the same folder of hfs.exe)
- look at the line starting by "port=" and report here on the forum what you read there
- now start hfs
- see if the port is the same of the one you read in the file

Offline chthonic

  • Tireless poster
  • ****
  • Posts: 121
  • I own the copyright to this image... "Back Off!"
    • View Profile
Re: unwanted port change
« Reply #6 on: January 27, 2010, 06:14:53 PM »
 ;D I already beat you to that idea! it says 80 .. and I am 100% certain it said 80 before the updates... I dont tamper with the default port... it was just odd that it was doing that..


after the manual change and save options to file..its not changing the port anymore

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: unwanted port change
« Reply #7 on: January 27, 2010, 10:22:45 PM »
the problem is solved?