Author Topic: Testing build #228  (Read 9598 times)

0 Members and 1 Guest are viewing this topic.

Offline chthonic

  • Tireless poster
  • ****
  • Posts: 121
  • I own the copyright to this image... "Back Off!"
    • View Profile
Re: Testing build #228
« Reply #15 on: March 07, 2009, 06:17:01 PM »
login hangs in firefox 3.07 if you type the wrong password.. it wont let you in at all.. but the problem doesn't happen in IE7

wasnt a problem with 3.06.. but not sure if its an issue with FF or HFS

Offline cmatte

  • Occasional poster
  • *
  • Posts: 31
    • View Profile
    • ErMeglio WebSite
Re: Testing build #228
« Reply #16 on: March 08, 2009, 01:34:52 AM »
login hangs in firefox 3.07 if you type the wrong password.. it wont let you in at all.. but the problem doesn't happen in IE7

wasnt a problem with 3.06.. but not sure if its an issue with FF or HFS
Mmh I'm using 3.0.7 and it does not hang if I put the wrong password, it simply asks for it again and shows the normal access denied page if you choose cancel..

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile
Re: Testing build #228
« Reply #17 on: March 08, 2009, 04:35:56 AM »
login hangs in firefox 3.07 if you type the wrong password.. it wont let you in at all.. but the problem doesn't happen in IE7

wasnt a problem with 3.06.. but not sure if its an issue with FF or HFS

No problems here either with FF 3.07 and HFS.
maverick

crazyboris

  • Guest
Re: Testing build #228
« Reply #18 on: March 08, 2009, 09:22:15 AM »
i was wrong the folder i put a password on had a copy inside another folder that wasent password protected.

so i had a exact copy of my folder inside another folder , and there was no pass on that.
thats why my "protected" files showed up..   :-[

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #228
« Reply #19 on: March 10, 2009, 01:26:27 AM »
i was wrong the folder i put a password on had a copy inside another folder that wasent password protected.

so i had a exact copy of my folder inside another folder , and there was no pass on that.
thats why my "protected" files showed up..   :-[

ok CB, we are happy this way, thank you for reporting :)

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #228
« Reply #20 on: March 10, 2009, 01:27:15 AM »
login hangs in firefox 3.07 if you type the wrong password.. it wont let you in at all.. but the problem doesn't happen in IE7
wasnt a problem with 3.06.. but not sure if its an issue with FF or HFS

since other people cannot reproduce your problem, could you test it on another computer?

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #228
« Reply #21 on: March 10, 2009, 01:56:49 AM »
guys, i cannot reproduce this TAR problem.
could you please provide a screenshot of the virtual file system, and a corrupted tar file?
send to support@rejetto.com

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #228
« Reply #22 on: March 10, 2009, 02:03:19 AM »
After downloading .tar using default tpl with 228, check boxes remain checked after
download is completed. Any furthur action on the folder/page causes the download
to start again.

this is how it is supposed to work.
if you want it to reset the selection by default, you can make a new poll (instead of "new topic") here on the forum.

anyone wishing to customize the behavior can change the onclick of the archive button to this

Code: [Select]
if (!confirm("Are you sure?")) return false;
submitAdding("filelist", {"action":"archive"}, "~folder.tar?recursive");
var is = document.getElementsByName("selection");
for (var i=0; i < is.length; i++) is[i].checked = false;

Quote
Selectable delete works in diff tpl, but after adding new selectable archive section, neither work.
Both work in main tpl.

in diff tpl? please tell me how to configure HFS to reproduce your problem.
« Last Edit: March 10, 2009, 02:05:20 AM by rejetto »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #228
« Reply #23 on: March 10, 2009, 02:07:50 AM »
selection(boolean) is not defined correctly at the end of addSelection();

ah, right, i will put this at the very beginning
selection:=FALSE;

Quote
and some subdirs or files in a real folder are not included or total size not correct :(

is this problem related to the value of selection:boolean ?
if not, can you tell me how to reproduce it ?

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #228
« Reply #24 on: March 10, 2009, 02:17:42 AM »
the only odd thign I have noted on my end is that the Live Template no longer functions with this build.

mmm, so it works if you revert to the last known working build?

Quote
add an option to force URL links to: target=_blank

lets discuss it at http://www.rejetto.com/forum/index.php?topic=6640.msg1041478#msg1041478

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #228
« Reply #25 on: March 10, 2009, 02:29:14 AM »
a new behavior in the user account option for this version.
the user accounts ignore limits OFF function works only after a vfs save.
when ignore limit ON works directly.

i just tested. removed the "ignore limits" from an account, and it was applied without a vfs save.
problem is/was that it required the connection to be reset. you could close all active connections, and then it was applied.
solved from next build.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #228
« Reply #26 on: March 10, 2009, 02:37:11 AM »
When I'm starting a file download with Google Chrome, and then abort it (at the prompt where to save) - HFS hangs up trying to send me this file.
I know, GC is a beta too, but...
All worked ok on IE7.

thanks for reporting, but there's nothing HFS can do with it. It's a bug of Chrome that has to be reported to google. The server doesn't know that you cancel or accept at the prompt.

Offline chthonic

  • Tireless poster
  • ****
  • Posts: 121
  • I own the copyright to this image... "Back Off!"
    • View Profile
Re: Testing build #228
« Reply #27 on: March 10, 2009, 12:21:04 PM »
login hangs in firefox 3.07 if you type the wrong password.. it wont let you in at all.. but the problem doesn't happen in IE7
wasnt a problem with 3.06.. but not sure if its an issue with FF or HFS

since other people cannot reproduce your problem, could you test it on another computer?

it's definitely a problem with FF on "some" machines... the login box doesnt always refresh itself and it keeps hanging on the mistyped password because its still in the buffer.. closing out the browser completely and reloading fixes the issue.

Offline r][m

  • Tireless poster
  • ****
  • Posts: 347
    • View Profile
Re: Testing build #228
« Reply #28 on: March 11, 2009, 06:25:44 AM »
anyone wishing to customize the behavior can change the onclick of the archive button to this

Code: [Select]
if (!confirm("Are you sure?")) return false;
submitAdding("filelist", {"action":"archive"}, "~folder.tar?recursive");
var is = document.getElementsByName("selection");
for (var i=0; i < is.length; i++) is[i].checked = false;

Alright ! ;D Workarounds are good ! The code above works (of course).
I thank you and my less than expert users thank you !