Author Topic: Testing build #141  (Read 11197 times)

0 Members and 1 Guest are viewing this topic.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Testing build #141
« on: November 08, 2007, 05:15:46 PM »
download @ www.dovedove.it/hfs/hfs141.exe

what's new
+ default template with search, sort by extension
+ new template symbol: %lang% (language identifier furnished by the browser)
+ new template symbol: %ip2name% (as %ip% but translated with the "Address 2 name" feature of the log) www.rejetto.com/forum/?topic=4894
+ new URL parameter: ?search=XXX (shortcut for ?recursive&filter=*XXX* )
+ workaround for IE6+SSL+XML+Flash+Compressed browsing
+ new macro: {{load|XXX}} where XXX is a filename or an URL to include
+ new macro: {{header|XXX}} where XXX is the http header field name to get
- default sorting by extension was not working

Offline Comrade Elisey

  • Occasional poster
  • *
  • Posts: 89
  • Cthulhu fhtagn! Cthulhu fhtagn!!!
    • View Profile
    • Dubophone
Re: Testing build #141
« Reply #1 on: November 08, 2007, 06:23:45 PM »
i'm not understand this adds:
Quote
+ workaround for IE6+SSL+XML+Flash+Compressed browsing
+ new macro: {{load|XXX}} where XXX is a filename or an URL to include
+ new macro: {{header|XXX}} where XXX is the http header field name to get
:-\

Offline Giant Eagle

  • Tireless poster
  • ****
  • Posts: 535
  • >=3 RAWR!
    • View Profile
    • RAWR-Designs.com
Re: Testing build #141
« Reply #2 on: November 08, 2007, 06:24:49 PM »
Could you explain a bit more about the {{header|XX}}??


About the search feature..
If the search returns no results, it now shows the contents of [nofiles], could it be possible to make it show the contents of [noresults] for example.
Cause telling the user that he either stumbled across an empty folder or his search didnt return any search results is a bit lame.

for the ppl that would not need [noresults], a simple [nofiles = noresults] would fix that ;D


And there is a bug:
Neither %folder% or %encoded-folder% return the correct folder path of the item that is being searched, if you simply add &recursive to the url it does show the path correctly.
« Last Edit: November 08, 2007, 06:45:01 PM by Giant Eagle »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #141
« Reply #3 on: November 08, 2007, 06:47:47 PM »
{{load|C:\windows\win.ini}}

and you will get your win.ini included in the template

{{header}} extracts values from the http header sent by the client within the http request. you probably don't need it.

Offline ELEVENNNN

  • Tireless poster
  • ****
  • Posts: 257
  • havent been here lately, still wont be here?
    • View Profile
Re: Testing build #141
« Reply #4 on: November 08, 2007, 10:44:24 PM »
Was reverse sorting implemented in this build, I tryed ?rev in the previous build and it did something but there didnt seem to be a solid result that made sense from it.. does it need to be used in conjunction with something else, I just tryed:

%host%/?rev

I didnt see this in the changelog, could someone explain a little and is it working for you?
Also, could someone using the default template please post a link to your fileserver, I'd like to see it.
« Last Edit: November 08, 2007, 10:46:19 PM by ELEVENNNN »
This is going to take a long time
.................+...........................................
...................+.............+.................+.........
......................................

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #141
« Reply #5 on: November 09, 2007, 01:24:55 AM »
if you want to see the default tpl, you can just use "temporarily disable options".

what you mean by solid result? does it work or is there a bug?

Offline TSG

  • Operator
  • Tireless poster
  • *****
  • Posts: 1934
    • View Profile
    • RAWR-Designs
Re: Testing build #141
« Reply #6 on: November 09, 2007, 02:00:28 AM »
Cool, I will implement ?search= as a non-js quick search. And that load macro, but thats for tonight, I have to go into city for while bbl.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #141
« Reply #7 on: November 09, 2007, 02:08:42 AM »
hint: someone will use the {{load}} to get text from other local servers, like apache

Offline Comrade Elisey

  • Occasional poster
  • *
  • Posts: 89
  • Cthulhu fhtagn! Cthulhu fhtagn!!!
    • View Profile
    • Dubophone
Re: Testing build #141
« Reply #8 on: November 09, 2007, 02:10:10 AM »
rejetto, tell me pls how to use {{load}}?
on example  :-[

Offline ELEVENNNN

  • Tireless poster
  • ****
  • Posts: 257
  • havent been here lately, still wont be here?
    • View Profile
Re: Testing build #141
« Reply #9 on: November 09, 2007, 02:10:53 AM »
Rejetto, thanks for the tip about the search, really easy way to do it.
As far as not getting a solid result, I meant each time I hit it it changed.  It wasnt like it was first doing a reverse sort, and then a normal sort... it completely changed, the results changed and there was some non ascii.  

I will upgrade to 141 and test when i get home. (leaving in 1 hour)

-Kurt
This is going to take a long time
.................+...........................................
...................+.............+.................+.........
......................................

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #141
« Reply #10 on: November 09, 2007, 02:21:25 AM »
kurt, it works fine here. try to find the way to reproduce the problem.

comrade, i already explained with an example in the other post.

Offline ELEVENNNN

  • Tireless poster
  • ****
  • Posts: 257
  • havent been here lately, still wont be here?
    • View Profile
Re: Testing build #141
« Reply #11 on: November 09, 2007, 03:18:58 AM »
I'm home now.  Working on it... would have sent you an IM but your off.

I'll let you know I find, it happened on 140 and I havent upgraded yet.
This is going to take a long time
.................+...........................................
...................+.............+.................+.........
......................................

Offline Foggy

  • Tireless poster
  • ****
  • Posts: 806
    • View Profile
Re: Testing build #141
« Reply #12 on: November 09, 2007, 05:37:49 AM »
+ workaround for IE6+SSL+XML+Flash+Compressed browsing

Thanks Rejetto, It works now. ;)

Offline ELEVENNNN

  • Tireless poster
  • ****
  • Posts: 257
  • havent been here lately, still wont be here?
    • View Profile
Re: Testing build #141
« Reply #13 on: November 09, 2007, 06:35:40 AM »
Rejetto, i can't reproduce that problem i was having anymore.. even on 140, i'll let you know if it arises again.

Foggy, you should get a site up that shows a demo of your flash player for lots of people to preview it and such, you could get a fairly loyal following.. I just enjoy rejetto's more because it's so clean, but if you could get yours a little more slimmed down and mainstream looking I think you've got a real shot.
This is going to take a long time
.................+...........................................
...................+.............+.................+.........
......................................

Offline yhm_7

  • Occasional poster
  • *
  • Posts: 55
    • View Profile
Re: Testing build #141
« Reply #14 on: November 09, 2007, 08:10:37 AM »
I can serch and get result,but can't open item.
example:search "1210",can get result,but it's wrong url that link to the item.

 http://218.244.71.16:9000/