Author Topic: Testing build #136  (Read 5619 times)

0 Members and 1 Guest are viewing this topic.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Testing build #136
« on: September 19, 2007, 12:12:50 PM »
download @ www.dovedove.it/hfs/hfs136.exe

what's new
+ Menu -> Other options -> "Accept any login for unprotected resources"
+ Menu -> Virtual File System -> "Backup saving"
+ improved handling of corrupted vfs files
* persistent graph in easy mode when manually enabled
* sorting disabled for recursive file listing
* %item-archivable% renamed to %item-archive%
- no more accepting invalid login for unprotected files
- no more loading or saving while adding files

Offline traxxus

  • Occasional poster
  • *
  • Posts: 62
    • View Profile
Re: Testing build #136
« Reply #1 on: September 19, 2007, 02:40:43 PM »
Runs good by me.
traxxus.dyndns.org:100

Offline yhm_7

  • Occasional poster
  • *
  • Posts: 55
    • View Profile
Re: Testing build #136
« Reply #2 on: September 19, 2007, 03:22:52 PM »
135 and 136
referer limit doesn't work.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #136
« Reply #3 on: September 19, 2007, 05:29:41 PM »
please, tell me how to reproduce the problem

Offline yhm_7

  • Occasional poster
  • *
  • Posts: 55
    • View Profile
Re: Testing build #136
« Reply #4 on: September 19, 2007, 11:32:01 PM »
with 135 136 

I had input "http://690.myip.org", but any one can browse any page and down files with my ip address or my other domain. I lookup the log of "request dump",referer is my ip or my other domain,this means that people can access hfs without any limit.

I also input "http://690.myip.org/" or "690.myip.org",but it's useless.

Former beta is ok.

Offline TSG

  • Operator
  • Tireless poster
  • *****
  • Posts: 1934
    • View Profile
    • RAWR-Designs
Re: Testing build #136
« Reply #5 on: September 20, 2007, 02:38:05 AM »
Symbol rename works. Haven't tested the rest.

Also.

My VFS appears to load A LOT faster now :) when did that performance increase occur :P

Offline Foggy

  • Tireless poster
  • ****
  • Posts: 806
    • View Profile
Re: Testing build #136
« Reply #6 on: September 20, 2007, 06:38:50 AM »
I also noticed a speed increase in loading the VFS, atleast I think its loading faster, probably imagineing it because you mentioned it. :P
« Last Edit: September 20, 2007, 08:07:19 AM by That_Stevens_Guy »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #136
« Reply #7 on: September 20, 2007, 08:11:51 AM »
with 135 136 
I had input "http://690.myip.org", but any one can browse any page and down files with my ip address or my other domain.

indeed, if you read the 135 what's new (4 lines all in all)
* "allowed referer" will always accept HFS itself as referer

this is not a bug, it's a design choice.
someone reported the previous behaviour as a problem.
i thought it was right because this feature was born to prevent hotlinking.
A good solution might be to have a "Prevent leeching" option for anyone, and a referer mask for experts.

Offline TCube

  • Tireless poster
  • ****
  • Posts: 445
    • View Profile
Re: Testing build #136
« Reply #8 on: September 20, 2007, 04:11:51 PM »
Salut à tous,

Back from # 131  ;D

up t'il now : yes latest beta are much faster [about VFS 5 600 items]   ;) ... I still like to know why I'm unable to LOGIN when HFS template remains the same and works fine with #124  ???

Which part of the template code would anyone need to help me out ?

TCube

Edit - late beta keeps replying :  "replying" at login request
« Last Edit: September 20, 2007, 04:14:17 PM by TCube »
Make it idiot-proof and I will make a better idiot

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #136
« Reply #9 on: September 20, 2007, 04:13:53 PM »
template? which one?

Offline TCube

  • Tireless poster
  • ****
  • Posts: 445
    • View Profile
Re: Testing build #136
« Reply #10 on: September 20, 2007, 04:19:49 PM »
Damn Template RV Brooks [note : not my browser ... same today at the public library few meters up the road]
« Last Edit: September 20, 2007, 04:22:52 PM by TCube »
Make it idiot-proof and I will make a better idiot

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12945
    • View Profile
Re: Testing build #136
« Reply #11 on: September 20, 2007, 04:24:26 PM »
isn't that template designed for HFS 1.6 ?

Offline TCube

  • Tireless poster
  • ****
  • Posts: 445
    • View Profile
Re: Testing build #136
« Reply #12 on: September 20, 2007, 04:33:07 PM »
isn't that template designed for HFS 1.6 ?

How the hell do I know ! conceptor 's gone missing for a long time  ... 'til then worked fine with stable udgrades
Plenty of things have been modified/improved since #124 (8 or 9 betas I believe) hard to tell if one new function would'nt  mess up things, no [i.e %login-link% ] ?

TCube
« Last Edit: September 20, 2007, 04:49:04 PM by TCube »
Make it idiot-proof and I will make a better idiot

Offline TSG

  • Operator
  • Tireless poster
  • *****
  • Posts: 1934
    • View Profile
    • RAWR-Designs
Re: Testing build #136
« Reply #13 on: September 21, 2007, 05:14:03 AM »
Ye, a lot of templates are getting very outdated now. So many new symbols and things. But i cannot see how an old template would stop working, because symbols have been added, not removed.

Offline TCube

  • Tireless poster
  • ****
  • Posts: 445
    • View Profile
Re: Testing build #136
« Reply #14 on: September 21, 2007, 06:51:51 AM »
Well, step by step ... #128 causes the problem. I'll ve to read the all thread about it. TCube
« Last Edit: September 21, 2007, 07:12:34 AM by TCube »
Make it idiot-proof and I will make a better idiot