Author Topic: Strano comportamento di HFS con browser con proxy  (Read 5304 times)

0 Members and 1 Guest are viewing this topic.

Fausto

  • Guest
Strano comportamento di HFS con browser con proxy
« on: December 17, 2006, 10:25:27 AM »
Premetto che utyilizzo HFS per condividere un Web Album con delle presentazioni fatte con Arles Images Web page.

Attualmente ho tre album condivisi nel HFS Http Server e mi capita la seguente stranezza:

n° 2 album nei quali uno riporta n° 1 sola foto, ed un altro circa 70 fotografie ed entrambi questi album si vedono perfettament enel mio browser configurato con proxy.

n° 1 album con circa 30 fotografie dove quando il browser è configurato senza proxy si vedono tutte le immagini, ma se lo configuro con il proxy alcune immagini mi danno strane scritte (come se mi facesse vedere il codice della pagina html invece dell'immagine)

Le stranezze di HFS sono:

a) tutti e tre gli slideshow sono stati creati con lo stesso programma (Arles Images Web Page);
b) senza proxy configurato nel mio browser Mozilla tutti e tre gli album si vedono perfettamente;
c) con proxy configurato nel mio browser Mozilla  n° 2 album si vedono perfettamente, mentre n° 1 mi dà l'errore (o meglio la visualizzazione di cui sopra);
d) ho provato ad accedere al mio server da un altro computer, in un altro edificio, con proxy aziendale ed internet explorer v6.0 e mi dà lo stesso tipo di errore, quindi non dipende dal mio computer.

Siete in grado di dirmi se anche a voi è capitata una simile situazione?


Offline al_z

  • Tireless poster
  • ****
  • Posts: 120
    • View Profile
Re: Strano comportamento di HFS con browser con proxy
« Reply #1 on: December 17, 2006, 12:19:10 PM »
Ciao

puoi, per favore, allegare uno screenshot del tuo problema?

AL

Fausto

  • Guest
Re: Strano comportamento di HFS con browser con proxy
« Reply #2 on: December 17, 2006, 03:28:17 PM »
Ciao

puoi, per favore, allegare uno screenshot del tuo problema?

AL
Ecco gli screenshots:
1) Snap1 è l'immagine che viene fuori nella presentazione di tutte le diapositive e qui và tutto bene;

2) Snap2 è l'immagine che si dovrebbe vedere quando clicco su ogni immagine del precedente passaggio;

3) Snap3 è invece l'immagine che a volte mi torna dal HTS server quando nel mio browser è attivata la funzione proxy

La cosa strana è che in altri show non mi si verifica mai.
Ad ogni modo sono sicuro che dipende dal proxy attivato nel browser perchè nel mio pc si verifica soltanto con Mozilla attivato su un proxy e la stessa cosa si verifica su un computer aziendale situato in tutt'altra parte della città e dove anche in esso è attivato un proxy aziendale.

Come mai?

E' questione di qualche settaggio che sbaglio?

Perchè anche con Mozilla attivato su proxy se faccio la Ricarica della Pagina a volte mi compare di nuovo la scritta, mentre invece altre volte appare l'immagine giusta?

Grazie per la Vs. gentilezza.



[attachment deleted by admin]

Fausto

  • Guest
Re: Strano comportamento di HFS con browser con proxy
« Reply #3 on: December 17, 2006, 03:32:50 PM »
Dimenticavo di dirvi che il mio server è all'indirizzo:
http://fausto-paesani.no-ip.info

fateci un giretto e vedrete che se andate con un proxy si verifica quello che ho descritto.

Grazie.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Strano comportamento di HFS con browser con proxy
« Reply #4 on: December 17, 2006, 04:23:34 PM »
Ci ho fatto un giro usando un proxy (143.205.172.11:3128) e come immaginavo mi funziona tutto.
Il tuo problema non ha niente a che fare con HFS, è quasi sicuramente un problema del tuo proxy. Considera che HFS nemmeno lo sa che passi da un proxy.

Visto che ci sono ti dico 2 funzioni che probabilmente non hai visto e che possono esserti utili.
Entrambe sono visibili solo in Expert mode.
Nel virtual file system fai click destro sulla home e ci trovi

1. bind root to real folder
che fa accedere le persone subito al tuo sito, senza prima dover clickare la cartella

2. default file mask
inserisci index.* e la gente non dovrà clickare sul file index per poter vedere il tuo sito, ma partirà in automatico.

Fausto

  • Guest
Re: Strano comportamento di HFS con browser con proxy
« Reply #5 on: December 17, 2006, 08:01:30 PM »
Ci ho fatto un giro usando un proxy (143.205.172.11:3128) e come immaginavo mi funziona tutto.
Il tuo problema non ha niente a che fare con HFS, è quasi sicuramente un problema del tuo proxy. Considera che HFS nemmeno lo sa che passi da un proxy.

Visto che ci sono ti dico 2 funzioni che probabilmente non hai visto e che possono esserti utili.
Entrambe sono visibili solo in Expert mode.
Nel virtual file system fai click destro sulla home e ci trovi

1. bind root to real folder
che fa accedere le persone subito al tuo sito, senza prima dover clickare la cartella

2. default file mask
inserisci index.* e la gente non dovrà clickare sul file index per poter vedere il tuo sito, ma partirà in automatico.

Ti ringrazio per l'interessamento e per la cortese risposta.

La funzione n° 2 l'avevo appresa tramite questo forum, ma non l'avevo abilitata perchè volevo vedere il Template che ho messo (copiandolo da uno di quelli immessi da qualche altro utente di questo forum).

Ora comunque l'ho abilitata come mi hai consigliato.

La funzione n° 1 invece non la sapevo e l'ho abilitata anch'essa.

Una sola domanda: ma che differenza c'è tra le due funzioni, non hanno lo stesso scopo?

Per ultimo ti ringraio ancora in quanto adesso si vede anche la mia iconcina (favicon.ico), mentre prima rimaneva fissa quella di HFS.

Ricollegandomi alla problematica che ho con il proxy ti garantisco che mi si presenta anche con un altro proxy aziendale, su altro sistema operativo e completamente differente configurazione rispetto a quello che utilizzo ora.

La cosa strana è che il problema si presenta sempre sulla stessa serie di fotografie (costituite dal gruppo centrale nella mia home page) e non sò proprio a che cosa sia dovuto.

Se vedo gli altri gruppi di foto non noto alcuna problematica, e questo da completo valore alla tua osservazione che il fenomeno non è di HFS (infatti se fossse dovuto ad HFS anche glli altri due gruppi di foto dovrebbero presentare lo stesso problema, ma non è così).

Ho anche rifatto la creazione della pagina html con Arles Image Web Page, ma nulla di risolto.

Pazienza, vorrà dire che rimarrà nel libro nero dei misteri.

Approfittando per ringraziarvi della vs. pazienza e per il tempo e le conoscenze che dedicate alla creazione, ed all'affinamento,  di questo ottimo programma colgo l'occasione per augurarvi un Buon Natale ed un Felicissimo e prospero Nuovo Anno 2007, a Voi ed alle Vostre rispettive Famiglie.

Grazie

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Strano comportamento di HFS con browser con proxy
« Reply #6 on: December 17, 2006, 08:11:26 PM »
le 2 funzioni sono molto diverse:
una associa all'indirizzo / una cartella,
l'altra evita di fornire la lista dei file, fornendo direttamente un file predefinito.