Author Topic: Internal IP address keeps changing  (Read 2187 times)

0 Members and 1 Guest are viewing this topic.

Offline wallywalters

  • Occasional poster
  • *
  • Posts: 13
    • View Profile
Internal IP address keeps changing
« on: May 29, 2014, 04:50:39 AM »
Whenever I reboot, the internal IP address for HFS is different.  Sometimes it's 192.168.0.101, sometimes 192.168.0.102, sometimes 192.168.0.104, etc.  And whenever it changes, the self-test fails and HFS obviously doesn't work.  How can I make the internal IP address permanent?  Editing the INI file doesn't seem to help.

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 837
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: Internal IP address keeps changing
« Reply #1 on: May 30, 2014, 02:42:48 AM »
Your machnie that is runing hfs is geting a new ip address(eitehr by restrat or by other things. You need to set your machine running hfs to a static ip adress(see below) with on the windows side or the router side (with mac adress resveration {DHCP reservation})

Previous post:
http://www.rejetto.com/forum/rawr-designs/how-can-ad-website-in-hfs-server-and-how-can-upload-in-website/msg1059129/#msg1059129

Sounds like you need to setup some basic networking to get things running!

-----------------

you will need to double check 3 things to make it use able over the web:

1. Windows side: ( i will assume you are using windows 7 ) at least i will post info link to windows 7...(most likely useable for all windows side os...)

You might need to set the "hfs machine" to a static ip address (this way when you open ports or use web traffice it has a "definite path"

windwos comand prompt:
cmd > "ipconfig /all"(<=command) has all the network info you need:
http://windows.microsoft.com/en-us/windows/change-tcp-ip-settings#1TC=windows-7

ip address is the machine address
subnet depends on your network most likely "255.255.255.0"
gateway is your router's ip adress most likely "192.168.1.1" (in your case it is 192.168.0.1)

you will need to allow hfs thorugh your firewall
http://www.sevenforums.com/tutorials/542-windows-firewall-add-remove-exception.html

2. Router/(intranet) network side
you router will need the port you chose in hfs (say you set the port to 8080 go to you router- in a web browser typ in the ip address of your gateway)

enable "port forward" to your machine and the router to the same port ie port (starting port) 8080 to port (ending port) 8080
http://www.wikihow.com/Set-Up-Port-Forwarding-on-a-Router

*note some router don't allow you to use your "public" ip address to view inside, so while your at home your webpage is accessible via the ip address you set to the machine earlier

(if your router supports it you can have it memorize you "hfs" machine "network address (known as a mac address) and assign it a specific ip address so it will always be "192.168.1.x" x being the number you set i chose 254 as it is the last number dhcp will use...

3. Internet/Modem side
go to http://www.ipchicken.com/
This is your public ip adress so when you are not at home you will go to this ip adress (xxx.xxx.xxx.xxx) what is shown at the website above one of many website that can tell you your public ip adress...

You should now have hfs viewable form the outside world via:
http://xxx.xxx.xxx.xxx:8080
(xxx your public ip address)

Since modems can be dynamic ip adress you can opt to get a "dns name so instead of typing xxx.xxx.xxx.xxx you type a predefined word such as mywebsite.(frre public domain).org

DNS free domains names:
either by adding it into the router or have it client side, or even pre-setup in a dns online website..

I'm having good luck with http://freedns.afraid.org/ using mooo.com as my public domain...(website presetup)
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline crazyboris

  • Tireless poster
  • ****
  • Posts: 140
    • View Profile
Re: Internal IP address keeps changing
« Reply #2 on: June 04, 2014, 07:20:58 PM »
just open router settings and set "lease time" to forever.