Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - r][m

Pages: 1 [2]
16
HFS ~ HTTP File Server / archive results
« on: March 07, 2009, 06:05:09 PM »
rejetto said
Quote
next version will let you archive even search results.

Can you give us any example of how to activate this?
Or perhaps include it in default tpl?

17
Bug reports / Time macro
« on: February 24, 2009, 06:34:24 AM »
Time macro doesn't work in build 225

Quote
{.time|ddd, mmm d, yyyy.}
displays "Tue, Feb 24, 2009 " in build 222

18
HFS ~ HTTP File Server / get | A
« on: February 15, 2009, 03:48:10 PM »
get | A
Using simple macro {.if|{.get|can recur.}| {.!1 can recur Works.} /if.} to test

can archive, can delete, can upload, can recur (work when those permissions are set)
can recur works any where when "Enable recursive listings" is checked (expected)

is new, can access (don't work)

 {.if not|{.get|can access.}|   (works everywhere - not expected)

Do is new and can access require another parameter? Reading the wiki didn't indicate that.

Rejetto, what am I missing here?

19
Bug reports / 3 Bugs
« on: February 06, 2009, 04:34:51 PM »
Bug # 1
  Descript.ion is broken in build 221, works in 220. Tested with default tpl.

Bug # 2
 Clicking on a restricted folder, and getting the log in window
 DOES NOT grant the same logged in priviliges/functions as using ~login.

  That's why I've been having so much trouble making macros and other code work.
  I use the first method, because I have a 4 page public web site in front of my server. Log in
  is by clicking a link to a folder that brings up the log in box.
  Maybe this was known, but I sure don't remember finding it on the forum, and I haven't missed reading
  much here in a couple of years.

Bug # 3
  Using ~login with the default template delivers "Page not found" from browser. On clicking
  back, you find you are in fact, logged in.
  #3 appears somewhat randomly, depending on the login method, I think.

Tested on build 221 with Firefox, Opera and IE on default tpl. Results consistent.
A fix might be an option to make ~login=/a directory of your choice/ instead of root.


20
Bug reports / Load Macro
« on: October 18, 2008, 03:22:21 PM »
Am I missing something, or does the load macro not work anymore?
I had tested it some time ago, and it worked. Now in 208 it doesn't.
From wiki:
load | A
you'll love this one. You can specify A as a file name, or as a URL. It will load and expand to it. The file or URL you specify must be accessible from the server machine. A can be
Code: [Select]
C:\windows\win.ini or also http://another_hfs_in_lan/the_file_i_want.txt.

21
HTML & templates / How to execute a macro?
« on: September 25, 2008, 07:21:39 AM »
Anyone have an example of how to make a macro run
only when a link or button is clicked ?

To execute a macro like {.exec|C:\Hfs_Test\analog\analog.exe.}

22
Bug reports / Date item-modified
« on: August 21, 2008, 04:11:31 PM »
Bug? ver 197 and 198 (all I've tested)
Using <meta http-equiv="content-type" content="text/html; charset=UTF-8" />

Date: %item-modified% in folder section appears as Date: 11/27/07 1:59:42 AM?
The ? on the end varies in different browsers. In Opera its a pipe, in Safari its a square
etc. Always on folder or subfolder, not file.
Going back to <META http-equiv=Content-Type content="text/html; charset=windows-1252">
it goes away.

Its a minor thing, but does any one else see this? Or do I have a system problem?

Same results with %item-added%

Pages: 1 [2]