rejetto forum

Software => &RQ => Topic started by: Matze on May 20, 2003, 10:51:53 AM

Title: Invalid "Online-Since time" in tooltip
Post by: Matze on May 20, 2003, 10:51:53 AM
Hi everyone!

I discovered a small bug: The user tooltip shows an invalid time in the info field "online since". Depending on my timezone (gmt+1) it shows a time one hour earlier than the correct time.
BTW the time shown in the message window with the event "UserX is online" is correct!

Nevertheless a very cool program! I'm using it for a very long time!  :)
Greetz, Matze
Title: Invalid "Online-Since time" in tooltip
Post by: rejetto on June 10, 2003, 05:22:26 PM
thanks for your kind words

this is my GMT offset code
Code: [Select]
GetTimeZoneInformation(TZinfo);
case GetTimeZoneInformation(TZInfo) of
  TIME_ZONE_ID_STANDARD: GMToffset:=TZInfo.StandardBias;
  TIME_ZONE_ID_DAYLIGHT: GMToffset:=TZInfo.DaylightBias;
  else GMToffset := 0;
  end;
GMToffset:=-(TZinfo.bias+GMToffset)/(24*60);

it works well in Italy
does someone see something wrong in it?
Title: Invalid "Online-Since time" in tooltip
Post by: rejetto on June 10, 2003, 05:22:52 PM
thanks for your kind words

this is my GMT offset code
Code: [Select]
GetTimeZoneInformation(TZinfo);
case GetTimeZoneInformation(TZInfo) of
  TIME_ZONE_ID_STANDARD: GMToffset:=TZInfo.StandardBias;
  TIME_ZONE_ID_DAYLIGHT: GMToffset:=TZInfo.DaylightBias;
  else GMToffset := 0;
  end;
GMToffset:=-(TZinfo.bias+GMToffset)/(24*60);

it works well in Italy
does someone see something wrong in it?

well in 0.9.4.12 i disabled it to make a test, but i re-enable it in 0.9.4.13