rejetto forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - rejetto

Pages: 1 2 3 4 5 ... 875
31
Beta / Re: version 2.4
« on: May 28, 2020, 01:28:47 PM »
Now a question as to how things are supposed to work.  I added the redirect back to the rejetto account, which sends it to \rejetto, the only folder it has access to.  But if I try to manually log in at the root, I just get prompted to log in again instead of being redirected to the \rejetto folder.  Is that working as designed?  I kind of expected the redirect to happen, but at least I probably won't actually have anyone trying to do that.

you are right. Fixed in next release.

Quote
And I think I found another bug.  If I click within or highlight the IP address part of a "user@xxx.xxx.xxx.xxx" entry in the log and try to ban it, the IP address field is blank (not that I would actually want to ban the IP address of someone who has an account. heh).

right. Fixed too.

32
Programmers corner / Re: delphi 10
« on: May 27, 2020, 09:49:56 PM »
mars, do you confirm that your problem is with your compilation and not with my exe?
if yes, moderate yourself  ;D and move your question to the programmers corner

33
Beta / Re: version 2.4
« on: May 27, 2020, 06:37:16 PM »
Oh, one more thing.  If I log in with an auth link, then log out without doing anything else in between that removes the auth part, it just automatically logs back in since it's still an auth link.  Would it make sense and would it be possible to just make the auth part go away while logging in?

ah, you are right, find this fix in this release

https://github.com/rejetto/hfs2/releases/tag/v2.4-beta06

34
Bug reports / Re: Dynamic DNS Updater with HTTPS
« on: May 27, 2020, 04:11:14 PM »
cool, thanks, i suspected that and it may be in time for 2.4
i'll give a look asap

35
Beta / Re: version 2.4
« on: May 27, 2020, 03:04:52 PM »
i just tested upload and comments with chinese characters, and had no problems.
Can you be more specific?

36
Bug reports / Re: Dynamic DNS Updater with HTTPS
« on: May 27, 2020, 10:28:26 AM »
thanks mars! maybe someone will be able to make a small plugin for easier integration on hfs

37
Beta / Re: version 2.4
« on: May 27, 2020, 10:25:05 AM »
I created a rejetto folder and user and restricted it to just that folder with full access, and the log below is from just the login process.  I will message you the link to log into it to see what happens if you'd like.  Don't worry, nothing malicious in there.  8)   Feel free to upload, create a folder, delete, whatever.

your link was precious because i've found ANOTHER bug.   ;D

If the account has a redirection, the mode=auth doesn't work well, you get the redirection on the next request (style.css).
I've decided that redirection should not take place at all with an auth link. It will work only with manual login. Ok?

I'll publish another beta later today. Already collected 6 small changes.

So I'm trying to narrow it down.
Edit: Nothing is standing out.  Even if I temporarily reset the options in the Debug menu, it doesn't help.  Only renaming hfs.ini out of the way makes a difference.  I need to get to bed.  Let me know if I should PM you my hfs.ini file.

i don't think the ini would be enough

38
Bug reports / Re: Dynamic DNS Updater with HTTPS
« on: May 26, 2020, 04:16:22 PM »
thanks for letting me know of this feature from google, anyway.
now i'm using it through the updater in my modem. :)

39
Beta / Re: version 2.4
« on: May 26, 2020, 02:54:37 PM »

40
Bug reports / Re: Dynamic DNS Updater with HTTPS
« on: May 26, 2020, 02:52:34 PM »
welcome to the forum!
sorry but https is not supported yet,
you'll have to use a different tool.

Or if you are a php programmer you may easily put a single line script on some server of yours that respond to simple http, proxying to google.

41
Beta / Re: version 2.4
« on: May 26, 2020, 01:04:26 PM »
I ran into a bug with the new "Copy URL with password" links.  After logging in, I think it's the style sheet that doesn't load.  The page is just text and basic buttons with no graphics. 

i just tried but cannot reproduce this problem. Let me know if you find more on it.

Quote
If I try to upload something it fails, but only after the entire file has been sent.  I have no idea where the file was being put as it was uploading, but it wasn't in the folder after it finished. 

ok i'll see to fix it for next release

Quote
I found out the hard way with an almost 14 GB file a friend tried to send.  Doh! lol  The problem appears to be with the fact that the part starting with "?mode=auth&u=...." is still in the address bar immediately after logging in.  If I click a folder button or link, that part is removed and the style sheet loads and uploads work.

oh man, sorry but i wouldn't use HFS for such job, as HTTP doesn't support resume on upload. Unless it's in LAN, and it takes few minutes.
TBH i suspect nowadays upload-resume could be implemented via javascript. Maybe for a future release.

42
Beta / Re: version 2.4
« on: May 26, 2020, 11:46:11 AM »
I couldn't get it to run on Windows 2000 SP4, so far. Have to check what the fresh system still lacks, in comparison to the established one that runs HFS fine. Maybe it is the IPv6 TP.

thanks. did you try older builds?

Quote
On a standard Windows XP installation with SP3, HFS will start, no problem, but it will be disabled and unable to be put online. That's because a standard install is missing the IPv6 component.

thanks for reporting. Solved in next release, for those who don't want to install ipv6

I hope you've seen the smileys. Just checked some old VMs and PCs and noticed. Personally, I'll start complaining when it stops working on Windows 7, OK? :)

i saw the smileys, but i was not worried, just surprised :D

43
Beta / Re: version 2.4
« on: May 25, 2020, 08:58:53 PM »
hi Tea, what version were you using?
the "leave disconnected" option was removed. If you need to keep track of connections you can use the log.

44
Beta / Re: version 2.4
« on: May 25, 2020, 04:26:22 PM »
I can confirm that. I have no bans.

ok, i've found the problem
https://github.com/rejetto/hfs2/releases/tag/v2.4-beta04


Looks like TWSocketServer have some unexpected behavior. I revert to TWSocket and it work as before

exactly.
twsocketserver is not compatible with the way i'm currently accepting connections.
in the future, when i shall probably switch to it for ssl, will have to make deepers changes. For the moment it was easier to just add a second socket for ipv6.

45
Beta / Re: version 2.4
« on: May 24, 2020, 06:24:49 PM »
https://github.com/rejetto/hfs2/releases/tag/v2.4-beta03

i introduced also a change with the template system: custom templates will be loaded as they were diff tpl. This mean that if you need a resource in your template, a section, that is present in the default template, you can avoid duplicating it in yours, and just consider as it is present. You can do it for css, and for the ajax.* sections for example. I hope this is not breaking anything.

Pages: 1 2 3 4 5 ... 875