rejetto forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - rejetto

Pages: 1 2 3 ... 884
1
Beta / Re: thumbnails
« on: August 11, 2020, 01:01:36 PM »
just as mars said.
if you need them to make cool stuff we can add them.

2
Beta / Re: thumbnails
« on: August 10, 2020, 10:02:12 PM »
I can't get the 'load' macro to run with images

i don't understand what you meant

3
it's probably not related to HFS. Your dns/domain or your ip may be unreachable for censorship or similar.
You can verify that by trying something that's not hfs.

4
Beta / Re: version 2.4
« on: August 04, 2020, 09:07:10 PM »
I'm not sure if this is related to RC6 only or all recent builds in general, but i've noticed that when someone downloads a file over LAN (and this is better noticable with big files that take longer to transfer), the HFS UI becomes completely unresponsive i.e. i can't click/nor interact with any button. The file transfer however still continues.
After the file transfer completes, the UI becomes responsive again.

this is a known problem. I think it happens also with HFS 2.3, you could check. This problem is happening with faster connections. HFS is not coping with it, and the only solution i know for the moment is to set a limit for the max speed in hfs. I advice setting it slightly lower than the actual max speed you are getting. Eg: if you are getting 100, try setting 90. But I noticed even setting 100 will give you some improvement. LMK
I hope someday we'll find a real solution to this.

5
Beta / Re: version 2.4
« on: August 04, 2020, 09:01:29 PM »
in the meantime take this fixed tpl

6
Beta / Re: version 2.4
« on: August 04, 2020, 05:19:42 PM »
Also checked with the default template and see that it was revised to archive selected.  This is good.  However, I did not get any archives.    And, then I tried again, selecting just 2 files for archive.  Didn't get an archive.   Also it didn't get stuck.   So, mostly good news. 

i always try to take my time in preparing the next release, but in the end i often make mistakes like this.
I'm not pissed off for the mistake itself, but because now the release is compromised and i have to make another.
irony appreciated tho.

7
Beta / Re: version 2.4
« on: August 02, 2020, 04:36:10 PM »

8
Beta / thumbnails
« on: August 02, 2020, 03:53:07 PM »
i've found that extracting the thumbnail that's sometimes embedded in a jpeg can be easy with a method that's probably not 100% reliable but took me little work.
I'm going to introduce this new feature even if the default tpl will not make use of it for now.
It can be considered experimental.
The feature works like this: you append ?mode=thumb to the url of a jpg file.
The thumbnail itself is served as a file. If not available you'll get a 404.
Generating a thumbnail is of course much worse on the CPU and poses some serious concerns: store it? and where?
It may be introduced in the future, but it's not a quick job as the one i just did.

You'll find it in the RC7 i'm going to release soon.

9
Beta / Re: version 2.4
« on: August 02, 2020, 03:26:44 PM »
Freezes when browsing if there are many files in the Real folder (about 250 files and folders). v2.3 is fine.

hi just tried a real folder with 1250 files and it took 2.5 seconds.
There must be something causing your problem but i don't know what.
See what happens if you click Menu > debug > temporarily reset options

Also, specify exactly the version you are using, and if you see "customized template" in the lower bar of the HFS window.

Quote
if upload speed is more than about 30MB/s and there are many connections (about 10), often server is dead without error message.
but the menu interface works normally.

do you confirm you are talking about "upload" to the server ?
what do you mean by "dead", what does the browser say?
does pressing F4 twice (start/stop) make it work again?

10
Beta / Re: version 2.4
« on: August 02, 2020, 03:07:36 PM »
I did not discover any other error.  But, I did discover that RC7 runs faster.  Kudos!!

the only optimization i know recently was in rc6, about file listing. Is that it?

11
Beta / Re: version 2.4
« on: August 02, 2020, 11:17:24 AM »
Archive message is good, but 'Cancel' button is missing.  So, the appearance is:  only choice is click ok? 

ok, i'll add ok/cancel buttons

Quote
Also probably don't need archive at root (a curious person like me, might click it just to see what happens).

assuming people don't need archive at root is both debatable and not solving the problem

Quote
Idea!  I think that you could relocate the archive button to the "Selection" sub-menu (archive can be next to the move button); so, then we can archive only what is selected.  That would be helpful. 

this is not solving but for the time being it could be a way to discourage wild actions

12
HTML & templates / Re: Tiles and Stripes, the gallery view
« on: August 01, 2020, 06:28:19 PM »
i noticed that problem 1 (not restricted to this template) especially on local networks (as they are faster) and seems to be solvable by setting a limit on the server.
Example, if you reach (using HFS) 50, you may get a sensible improvement already by setting 50 as a limit, and even better if you lower it.

13
Beta / Re: 2.4 translation
« on: July 27, 2020, 10:13:26 PM »
I could just remove that specific [+special:strings]  but it's there for a reason, and it's to make source text more "stable", so that translations need less updates.
I should use it even more, actually.
But that problem is compromising the very sense of that feature, impeding people to make translations :D
One possible solution is to have an alternative to the + operator to prepend instead of to append. As symbol I would use ^ .
Prepending would give priority to the customization.
This should be quick and easy to make for me, and technically good.

14
Beta / Re: 2.4 beta unicode problem
« on: July 27, 2020, 09:15:44 PM »
i'm going to use a standard Windows' function "IsTextUnicode" that guesses the format of the ouput.
it's not 100% reliable but that's it.

For example, this is "normal" dir listing
{.exec|cmd /c dir tmp\*.txt|out=x.}{.^x.}

Code: [Select]
08/06/2020  11:27             1.004 post-data.txt
07/07/2020  14:58               607 swipe panels.txt
10/02/2004  17:01             3.100 ?.txt
10/02/2004  17:01             3.100 ?.txt
10/02/2004  17:01             3.100 ?è?.txt
               7 File         16.524 byte


and this is when /u will produce unicode output
{.exec|cmd /u /c dir tmp\*.txt|out=x.}{.^x.}
Code: [Select]
08/06/2020  11:27             1.004 post-data.txt
07/07/2020  14:58               607 swipe panels.txt
10/02/2004  17:01             3.100 會.txt
10/02/2004  17:01             3.100 生.txt
10/02/2004  17:01             3.100 生è生.txt
               7 File         16.524 byte

this result is possible only in next release

15
Beta / Re: 2.4 beta unicode problem
« on: July 27, 2020, 01:48:36 PM »
i started studying the problem, but it's not trivial.
apparently the output of consoles can be "oem" or unicode.

Pages: 1 2 3 ... 884