Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - help420me

Pages: [1]
1
Bug reports / MD5 Checksum bug
« on: July 16, 2007, 04:09:46 AM »
I just switched a large folder with a lot of subfolders and files into a real-folder in the HFS interface.  The program started generating md5 checksum files named .md5.  The thing was, it started creating a new file for each new file, eg somefile.md5 had a file named somefile.md5.md5 created, and then somefile.md5.md5.md5, and then... well, you get the picture.

The fingerprints option shows disabled and I don't use md5 checksum files through HFS.  This obviously filled my directories with worthless 32KB files (my cluster size) until I turned off and shutdown the server.

Any new information I get I'll post as I get it. ???

edit:

I now believe this to be a bug or lack of errortrap in the md5 checksum generation code.  Disabling md5 checksum generation for files ending in .md5 would fix this immediately.

 ;D

edit:

WORKAROUND

The menu shows the function is Disabled, but there's a checkmark next to save new calculated fingerprints.  The filesize was set to 420.

I enabled fingerprints, cleared the checkmark, and reset the size to 0 to disable the function.

I searched for *.md5 on all my harddrives and deleted most of them, some i needed.

I'm back online now.

2
Everything else / My newly updated HFS powered website
« on: July 14, 2007, 08:36:29 AM »
just wanted to invite everyone over.  I'll make the vfs and tpl available for download in the morning.

the site is http://h4m.dontexist.net which is a mirror of http://help420me.kicks-ass.net

enjoy!

3
Bug reports / Template bug in 2.0 beta44
« on: August 22, 2006, 08:24:17 AM »
I don't know if this has been fixed in the latest updates, so I'll try on those soon.  When using the template variable %build-time% to indicate how long a page took to generate, the number comes up in normal pages.  However, on any of the Error pages, the number doesn't come up and only the %build-time% is displayed.  I've tried different things to get it to work, but it doesn't come up at all.  Tried wrapping it in a js file, changing the css, terminating it with /n, adding it to the individual error secctions (like [not found]) but nothing works.  I've edited the [error-page] to look like this:

Code: [Select]

[error-page]
<html><head><title>ERROR</title>
<script type="text/javascript"><!--
function get_random() {var ranNum=Math.floor(Math.random()*5);return ranNum;};function getaBackground(){var whichBack=get_random();var back=new Array(5);back[0]="/american.gif";back[1]="/fatalerror.jpg";back[2]="/crack.jpg";back[3]="/saderror.jpg";back[4]="/warcraft.jpg";var BG=back[whichBack];return BG;}document.write('<img src=' + getaBackground() + ' height=100% />');//-->
</script><style>\n%style%\n</style></head><body>
%content%
<hr>
<div style="text-align:center;font-weight:bold;"><a href="http://www.rejetto.com/hfs/">HttpFileServer %version%</a><br>Serve Time: %timestamp%<br>Uptime: %uptime%<br>Page Generation: %build-time%<br>Server Connection Speed: 30KB/s for all %number-addresses% computers connected<br></div></body></html>


It's just a random array with possible images for the error background image with some server info at the bottom. But even leaving it at default and adding the %build-time% var doesn't work either.

Regards.

Pages: [1]