Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - KalleB

Pages: [1] 2 3 ... 7
1
Beta / Re: Testing build #217
« on: December 22, 2008, 08:39:48 PM »
Small and irrelevant bug: I happened to have an image file with modification year 28331 (caused by some bug in xnview when saving). In Windows Explorer in detail-view this file had no modified date at all, but from preferences I cound see this future date. When I tried to open the folder where this image was on my browser, HFS just did not serve it...did not crash or freeze but just did not open the folder..or allowed archive download.

So does this mean I can't use HFS anymore in the 284th century?  :D

2
Beta / Re: Testing build #185
« on: April 16, 2008, 09:28:05 PM »
2. macros inside a vfs may delete random files on your hard disk. do you still think i should not warn people about it?

Yes, of course it's good to warn people. But would it be possible to make HFS 'scan' through the vfs file for those certain macros that might modify/delete any files and only display the warning when this kind of commands are found?

3
Beta / Re: Testing build #185
« on: April 11, 2008, 03:00:51 PM »
So after a long time I updated my HFS and right after that I got this huge screaming WARNING!!! message about some macros right to my face... The message did not even specify what file this was all about nor what this "macros" thing means in the first place..

Now don't get me wrong, I know what macros are and I know that warning was propably about my default VFS file, but for a novice this kind of message is quite scary and could easily induce a "WTF!!11" reaction.

So please rejetto, make that message a bit more informative and lessen the exlamation marks :)

4
Beta / Re: Testing build #164
« on: December 19, 2007, 10:30:17 PM »
Indeed.. But with the possibility to translate the template coming up, I'd like to input my own thoughts about the default style. You see I translated and also re-styled the previous default template into my own template but the new one seems to have changed so much that I'd have to do all that all over again...and I think I'll just try to live with the new default one ...but some things in it are just too much not to my taste and I hope rejetto would agree with me about them :D

5
Beta / Re: Testing build #164
« on: December 19, 2007, 08:28:33 PM »
i like this asymmetry.
I'm sorry to hear that :( This asymmetry hurts my eyes like hell.. :D
Please at least make the heavy lines a bit thinner, you can still keep the dots :P

a button that looks like another thing may mislead the user. (usability matter)
The other buttons in the HFS page look more like this my "etsi" button...for example the old "Login" button and the new ".: Menu :."...they all have this 2D look, the default 3D-button doesn't go with the overall page style I think.

6
Beta / Re: Testing build #164
« on: December 18, 2007, 10:30:28 PM »
The new HFS is starting to look and feel pretty good I think..  :) But there's still a couple of style issues in the default template that I'm not totally comfortable with:

  • Attachment #1 - The dotted borders at the sides and heavy ones on top and bottom should be equally thick. Same thing with the comment borders.

  • Attachment #2 - The search field and the button can be easily blended in by adding tag class=row when using the old template. I don't know which class would do this with the new template but I'd hope to see it looking like this in the future releases.
    (the text "etsi" should of course be "search" - the image is from my translated template :D)


Also, when using the new template, I would not like to see these "Requested GET /~style.css" and "Requested GET /~style.menu.css" in the log every time a folder is opened.

7
Beta / Re: Testing build #145
« on: November 23, 2007, 11:16:54 AM »
Thanks! Search now working right with my VFS :D

Feature Request: Archived download of all the search results. Shouldn't be too hard to implement? Except, I't might be difficult to make it not to override the "Archivable" selection...or maybe it should override it.

8
RAWR-Designs / Re: RAWR - Advanced Search, for use on any template.
« on: November 21, 2007, 03:44:48 PM »
I don't know too much HTML+CSS but would it be possible to put these "Recursive", "File(s)", "From Current Directory" (and so on) into a similar menu that the current HFS default template has? Then these selections would not be visible all the time but only when mouse is over the search field...

9
Beta / Re: Testing build #144
« on: November 19, 2007, 02:09:15 PM »
Bug (or just a beta feature?): "Links before" state not saved when closing.

10
Beta / Re: Testing build #144
« on: November 15, 2007, 09:41:02 PM »
Rejetto: search still not working right when I use my old VFS file...sent you e-mail about it.

11
Beta / Re: Testing build #143
« on: November 13, 2007, 03:33:41 PM »
I have trouble with ~folder.tar?recursive. I need that users cant save folder.
Can You do option to disable save folder as You done with recursive.
ps: Option Recursive need to be enable for searching
Help!!

In folder menu, just remove the option "Archivable" for that folder and you can keep the recursive option enabled in the main menu.


And about Alons0's Back-button debate...I'd also like there to be a "Return" or "Back" link there where normally is the "UP" link. I don't like to use the browser buttons.

12
Beta / Re: Testing build #142
« on: November 12, 2007, 07:37:20 PM »
Quote
you are saying that the same HFS gives different results on localhost and over the network?
your vfs file may eventually be useful to understand your case.

No that's not what I ment. Anyway it turns out there's something wrong with my VFS file. I created a new one and the search worked with it. Could it be that there just was too much files & folders in the previous one so the search choked? I'll see if I could send you my VFS that is not working...

Quote
searching in the folder only may come later.
It's already possible when I just remove the "/" from the action=''...at least with Opera.

Quote
i know you are used to that, but i think it is more visible on the left, and since it will contain almost all "features", it should not be missed.
I don't think I'm used to it (I hardly ever use the Login button) but I think the menu shouldn't overlap with these texts:
folder
/Downloads/
 UP
11 folders, 10 files - Total: 2,17 GB


...as it does now. What if you're f.ex. just about to click that "Folder archive" but you'd like to check what size the folder was with a quick glance...you can't because the menu is on top of it :D There's plenty of room for the menu and the search in the right corner..It looks empty now. The menu button also pushes the page contents even lower (being above the "folder" text), which does not look nice.

And also, the ".:" and ":." should not exist...

13
Beta / Re: Testing build #142
« on: November 11, 2007, 05:11:03 PM »
Quote
Try searching for 'heroes*.avi'

No change what so ever... I get 3459 files - total: 10,73 GB.
With *.avi I get 3487 files - total: 23,30 GB
With heroes: 3465 files - total: 10,73 GB
With DSC01305.JPG: 3452 files - total: 8,34 GB
With asdasdasdd: 3452 files - total: 8,34 GB
With "buggy search": 3452 files - total: 8,34 GB

...so there's really no logic :D

On my other 2 PCs with b142 the search works perfectly in the root though... Same build, same template, same OS, pretty much the same software, same browser.

14
Beta / Re: Testing build #142
« on: November 11, 2007, 03:24:48 PM »
Nice to see the search function finally :D

There seems to be some problems with it anyway:
Searching in root directory for *.avi or heroes for example lists almost all my files and folders. Searching for * returns even more items, pretty much all I think.

Searching in a subfolder works fine if I edit the template and change the form action='/' into action=''. Then I get correct results for the *.avi search for example...but not in root directory.


PS: How about moving the ".: Menu :." to the upper right corner...where the login used to be?

15
Beta / Re: Testing build #133
« on: September 11, 2007, 08:28:26 PM »
There might me some problems with download limits. One user was downloading two files from me, simultaneous downloads set to 20, from same address 7 and he got the "download limit reached" notification. The downloads were not in sections, they were normal downloads. I will try and reproduce when I have time... I think this might be related to that disconnection problem.

Update: I was not able to reproduce this.. At least not when downloading from 127.0.0.1

Pages: [1] 2 3 ... 7