Author Topic: Login Button leads to Error Message  (Read 1324 times)

0 Members and 1 Guest are viewing this topic.

Offline kotsch

  • Occasional poster
  • *
  • Posts: 3
    • View Profile
Login Button leads to Error Message
« on: January 24, 2018, 10:31:08 AM »
I now can access the Webpage via IE.

But when I click on the Login Button I get the error message:

Unauthorized
Either your user name and password do not match, or you are not permitted to access this resource.
HttpFileServer 2.3k
1/24/2018 11:29:40 AM


When clicking on the secured folder, I get the same Message. I get not prompted at all to enter my credentials.

Opening the Page on my Server using http://localhost the Login Button works as expected.
But opening on my Client using http://servername the Error Message above appears.
The Firewall is well configured. I can see the Homepage and I can click through my unsecured folders. But securing a folder and get in does not work.

I cannot push the URL because it is in my private network.

I found out, that the Login is possible on all machines where no Firewall is between.

The firewall to my Client PC allows Port 80. I can see the Homepage, but can't login.
Is there anything else to be opened in the Firewall ?
« Last Edit: January 24, 2018, 01:56:23 PM by kotsch »

Offline Mars

  • Operator
  • Tireless poster
  • *****
  • Posts: 1842
    • View Profile
Re: Login Button leads to Error Message
« Reply #1 on: January 24, 2018, 06:57:24 PM »
first: never use  "set user/pass on context menu", preferable use of access permissions (folder properties menu) to assign permissions to some users or groups, or to guests or anyone.
you can also check "List protected items only ...." in Menu> Virtual file system" to hide the resources to any user who does not have a right of access to thoses

Offline kotsch

  • Occasional poster
  • *
  • Posts: 3
    • View Profile
Re: Login Button leads to Error Message
« Reply #2 on: January 25, 2018, 08:36:36 AM »
Thanks for your answer - but

Thats what I did. No you don't understand my question.

Everything works as expected on the Server itself. But starting the Page from my Client and Clicking on "Login", I get the message

Unauthorized
Either your user name and password do not match, or you are not permitted to access this resource.


On the Server it is o.k. That means, I don't get the Login Screen at all on my Client.

I think, it has something to do with the IE Settings. The URL on my Client is save in the Zone: Internet. On the Server it is on Trusted Sites.

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 788
  • I'm only trying to help i mean no offense.
    • View Profile
    • none - google translate
Re: Login Button leads to Error Message
« Reply #3 on: January 26, 2018, 03:37:12 AM »
Try cleaning the browsers history and cache.

Specific the cookies
This sounds like an error I. The hfs cookie and the session id generation.
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12890
    • View Profile
Re: Login Button leads to Error Message
« Reply #4 on: January 26, 2018, 03:02:24 PM »
i tested on this computer and it's even worse: i get a blank page  :-\
I will look into it asap, but IE it's a strange choice in 2018 :)

Offline kotsch

  • Occasional poster
  • *
  • Posts: 3
    • View Profile
Re: Login Button leads to Error Message
« Reply #5 on: January 30, 2018, 08:09:36 AM »
I refreshed everything - but it does not allow to login.

I have tested it with a portable Firefox Browser - here it works.

So it has something to do with my IE or with the IE Internet Policy Settings. I'm going to try to enter the URL into the Trusted Site Section of the Internet Options.

I'll come back with the result here.

Thanks for all your replies.