Author Topic: A problem with loading template  (Read 32685 times)

0 Members and 2 Guests are viewing this topic.

Offline Comrade Elisey

  • Occasional poster
  • *
  • Posts: 89
  • Cthulhu fhtagn! Cthulhu fhtagn!!!
    • View Profile
    • Dubophone
Re: A problem with loading template
« Reply #15 on: August 14, 2007, 02:37:50 AM »
there is video (xvid) about template bug.
http://coel.ath.cx/bug/template_bug.7z
notes: coel.tpl is my small template which HFS load succesfully;
HFS Terayon v1.2.1.tpl & en_basic_blue_2009.tpl is big for HFS...

Offline radd

  • Tireless poster
  • ****
  • Posts: 145
    • View Profile
Re: A problem with loading template
« Reply #16 on: August 14, 2007, 05:53:03 AM »
hmm.. anybody use win98 with same problem?

Offline TSG

  • Operator
  • Tireless poster
  • *****
  • Posts: 1934
    • View Profile
    • RAWR-Designs
Re: A problem with loading template
« Reply #17 on: August 14, 2007, 11:02:03 AM »
You are experiencing a very strange bug... I decided to do some testing to see how many characters the template editor could handle with copy/paste... I managed to get the following results.... ;D 117mb template anyone.?. i must say HFS was getting laggy with all that memory usage :P

What exactly is your problem? is it that you cannot import a template that big, or your bandwidth is too slow for the template... or you HFS just wont physically show the template even with local hosting?

*i would have looked at the video but the link is offline*

My specs are as follows:
2.2ghz AMD Athlon 3500+
4x512mb = 2gb 400mhz DDR RAM
60gb IDE, 200gb SATA, 320gb SATA = 580gb total HDD space...


I think HFS could have taken more but CPU usage was peaking rapidly :P
« Last Edit: August 14, 2007, 11:17:53 AM by That_Stevens_Guy »

Offline Comrade Elisey

  • Occasional poster
  • *
  • Posts: 89
  • Cthulhu fhtagn! Cthulhu fhtagn!!!
    • View Profile
    • Dubophone
Re: A problem with loading template
« Reply #18 on: August 14, 2007, 12:45:44 PM »
my hfs is always online, but sometimes i restarting the computer...
try download now  :)

Offline TSG

  • Operator
  • Tireless poster
  • *****
  • Posts: 1934
    • View Profile
    • RAWR-Designs
Re: A problem with loading template
« Reply #19 on: August 14, 2007, 02:33:05 PM »
Wow, just watched the video, that is very strange, those templates aren't that huge either...

I used to run my HFS from a 500mhz PIII with 320mb of ram, on windows 2000. And i found everything i threw at HFS would work. I find this puzzling... And as you can see using a computer with 2.2ghz, 2gb RAM and windows XP you can get up to 117mb and higher templates happening :P as if u'd ever use that tho.

I have a feeling its your processor... When you paste in the template code, take a look at the amount of CPU HFS is using in your task manager. With 117mb template, it raced up to 1,200,000k for hfs.exe. Maybe. I am unsure. It could even be windows98 at fault. But i doubt it because HFS is actually running and you can use a smaller template. Which to me says you computer can only handle so many characters in the template editor...This is just my theory, don't count on it :P

Offline Comrade Elisey

  • Occasional poster
  • *
  • Posts: 89
  • Cthulhu fhtagn! Cthulhu fhtagn!!!
    • View Profile
    • Dubophone
Re: A problem with loading template
« Reply #20 on: August 14, 2007, 02:39:45 PM »
maybe rejetto can fix this bug for win98?  :-\

Offline MarkV

  • Tireless poster
  • ****
  • Posts: 745
    • View Profile
Re: A problem with loading template
« Reply #21 on: August 14, 2007, 04:39:55 PM »
Could you run the resource monitor please? And what it says when you try to load the template. Especially User and GDI resources. It may be that is your problem.

Also please read this article, it may have to do with your issue: http://apptools.com/rants/resources.php
http://worldipv6launch.org - The world is different now.

Offline Comrade Elisey

  • Occasional poster
  • *
  • Posts: 89
  • Cthulhu fhtagn! Cthulhu fhtagn!!!
    • View Profile
    • Dubophone
Re: A problem with loading template
« Reply #22 on: August 14, 2007, 04:45:07 PM »
maybe maybe...

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12888
    • View Profile
Re: A problem with loading template
« Reply #23 on: August 15, 2007, 06:03:30 PM »
why you say the problem is the size? couldn't be something else?

try this
  • open the terayon file
  • find this line: <meta http-equiv="content-type" content="text/html; charset=UTF-8" />
  • remove it and save
  • see if the problem persists

i don't have Win98, and it's not officially supported. i may try getting a virtual machine running it.

Offline Comrade Elisey

  • Occasional poster
  • *
  • Posts: 89
  • Cthulhu fhtagn! Cthulhu fhtagn!!!
    • View Profile
    • Dubophone
Re: A problem with loading template
« Reply #24 on: August 15, 2007, 06:09:47 PM »
the problem is persist  :(

Offline radd

  • Tireless poster
  • ****
  • Posts: 145
    • View Profile
Re: A problem with loading template
« Reply #25 on: August 15, 2007, 06:28:42 PM »
have u try copy & paste the code little by little? i know this shouldnt be the right way to do, but just to check where the problem lies in ur case. whether hfs couldnt stand too many character in template editor or the problem start during the "copy" process.
if u can paste let say half of template, then paste another half and the template are working, most probably problem during copying. not enough memory? or like markv said? i dont know..

Offline Comrade Elisey

  • Occasional poster
  • *
  • Posts: 89
  • Cthulhu fhtagn! Cthulhu fhtagn!!!
    • View Profile
    • Dubophone
Re: A problem with loading template
« Reply #26 on: August 15, 2007, 06:33:48 PM »
i try copy & paste little by little, but when limit is archieved i can't type any  character...

Offline radd

  • Tireless poster
  • ****
  • Posts: 145
    • View Profile
Re: A problem with loading template
« Reply #27 on: August 15, 2007, 06:59:11 PM »
hmm.. looks like template editor itself having limit. rejetto might want to look at this. sorry, i use winxp, cant confirm your problem.

p/s- your templates very nice though, and fast. i might suggest u stick on this template unless u need the extra part like mp3player, thumbnail view.. and i love your avatar too, where did u get them.. hehe

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12888
    • View Profile
Re: A problem with loading template
« Reply #28 on: August 15, 2007, 09:18:14 PM »
i try copy & paste little by little, but when limit is archieved i can't type any  character...

and what is this limit?

Offline MarkV

  • Tireless poster
  • ****
  • Posts: 745
    • View Profile
Re: A problem with loading template
« Reply #29 on: August 16, 2007, 02:12:21 AM »
Meh... I still think his resources are depleted. It would explain the 9x vs. NT thing. NT based OS have unlimited resources (only limited by RAM), while Windows 98's GDI and user resources are only 2MiB each - shared for ALL programs running. If you run some resource-intensive programs, 98 goes down the drain...
http://worldipv6launch.org - The world is different now.