Author Topic: Invalid "Online-Since time" in tooltip  (Read 1266 times)

0 Members and 1 Guest are viewing this topic.

Matze

  • Guest
Invalid "Online-Since time" in tooltip
« on: May 20, 2003, 04:51:53 AM »
Hi everyone!

I discovered a small bug: The user tooltip shows an invalid time in the info field "online since". Depending on my timezone (gmt+1) it shows a time one hour earlier than the correct time.
BTW the time shown in the message window with the event "UserX is online" is correct!

Nevertheless a very cool program! I'm using it for a very long time!  :)
Greetz, Matze

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12844
    • View Profile
Invalid "Online-Since time" in tooltip
« Reply #1 on: June 10, 2003, 11:22:26 AM »
thanks for your kind words

this is my GMT offset code
Code: [Select]
GetTimeZoneInformation(TZinfo);
case GetTimeZoneInformation(TZInfo) of
  TIME_ZONE_ID_STANDARD: GMToffset:=TZInfo.StandardBias;
  TIME_ZONE_ID_DAYLIGHT: GMToffset:=TZInfo.DaylightBias;
  else GMToffset := 0;
  end;
GMToffset:=-(TZinfo.bias+GMToffset)/(24*60);

it works well in Italy
does someone see something wrong in it?

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12844
    • View Profile
Invalid "Online-Since time" in tooltip
« Reply #2 on: June 10, 2003, 11:22:52 AM »
thanks for your kind words

this is my GMT offset code
Code: [Select]
GetTimeZoneInformation(TZinfo);
case GetTimeZoneInformation(TZInfo) of
  TIME_ZONE_ID_STANDARD: GMToffset:=TZInfo.StandardBias;
  TIME_ZONE_ID_DAYLIGHT: GMToffset:=TZInfo.DaylightBias;
  else GMToffset := 0;
  end;
GMToffset:=-(TZinfo.bias+GMToffset)/(24*60);

it works well in Italy
does someone see something wrong in it?

well in 0.9.4.12 i disabled it to make a test, but i re-enable it in 0.9.4.13