Author Topic: Bugs 0.9.1.5  (Read 1408 times)

0 Members and 1 Guest are viewing this topic.

Offline joxy

  • Experienced poster
  • ***
  • Posts: 88
    • View Profile
Bugs 0.9.1.5
« on: July 18, 2002, 01:08:38 AM »
The following is about 0.9.1.5.

When it shows "birthday", then it shows the correctly formatted date of the form dd.mm.yyyy (russian standard).  The dropdown calendar works & applies dates, for my info.
When it shows "age", it shows either "Unspecified", or the correct age with spin control.

Bug1a.
Situation: in my info, when i choose "birthday" and enter the date (using dropdown chooser), it applies the date correctly
Bug: here, when I hit "save my info", it shows "your information has been saved", and when this msgbox is displayed, the "unspecified/age/birthday" dropdown is reset to "unspecified".  
After that, if I hit "retrieve my info", the "unspecified/age/birthday" dropdown is reset to "birthday", and the birthday field is initialized with values I entered before hitting "save my info".  

Bug1b.
After that, if I choose "age" of "16", hit "save", then the "unspecified/age/birthday" dropdown is reset to "birthday", and the birthday field is initialized with values I entered in the Bug1a process.
After that, if I hit "retrieve my info", the "unspecified/age/birthday" dropdown is reset to "age" of "16".

Bug1c:
After that, i choose "unspecified", hit "save", the "u/a/b" field is reset to "age" of "16".
After that, if I hit "retrieve my info", the "unspecified/age/birthday" dropdown is reset to "unspecified".

Bug2a:
When I select "age", and enter an empty string there, and hit "save", strange value is stored  (I saw "13").  Try hitting "retrieve".

Bug2b:
When I select "age", and enter "-" there, as an age string, and hit "save", the behavior is the same as in Bug2a.

Bug3:
When I hit CtrlBackSpace in the chatmsg editor, when the cursor is located in the middle of the first word after end-of-line character, the start of the word is deleted, and the cursor is relocated to the end of current line.  Should be at the start of current line.

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12852
    • View Profile
Bugs 0.9.1.5
« Reply #1 on: July 18, 2002, 11:20:37 AM »
bug1 is due to a delay of the server in saving datas, i have to find the best way to wait for the server. or maybe i won't retrieve new datas from the server, but this would lead to an harder bug detecting.

bug2 it is not a bug, the server won't accept a value less than 13

bug3 fixed