Author Topic: server stops accepting connections  (Read 3617 times)

0 Members and 1 Guest are viewing this topic.

woodfold

  • Guest
server stops accepting connections
« on: July 24, 2012, 10:44:47 AM »
I'm using the event script with v2.3 build 280 to stop and start the server for maintenance. I tested the stop/start entries at 5pm and it looked good. Then I set the stop time to midnight and after that time passed, I noticed the log panel had a date, but no time entry for the stop command. I check the log file and it has the same problem, no time.

Below is:
 the log, showing a good entry, (IPs changed, password entries removed)
 the event code
 screen capture of the log panel

Code: [Select]
2012-07-23 4:56:32 PM xx.xxx.x.xxx 54702 Requested GET /
2012-07-23 5:00:00 PM Server stop
2012-07-23 5:00:00 PM Server Stopped
2012-07-23 5:05:00 PM Server start
2012-07-23 5:05:00 PM Server Started
2012-07-23 6:11:32 PM xx.xxx.x.xxx 55382 Requested GET /
2012-07-23 6:36:40 PM xx.xxx.x.xxx 60090 Login:  /
2012-07-23 6:48:24 PM xx.xxx.x.xxx 49247 Requested GET /
2012-07-23 6:50:58 PM xx.xxx.x.xxx 49296 Requested GET /
2012-07-23 6:56:43 PM xx.xxx.x.xxx 60313 Requested GET /
2012-07-24 Server stop
2012-07-24 Server Stopped
2012-07-24 12:30:00 AM Server start
2012-07-24 12:30:00 AM Server Started
2012-07-24 1:37:51 AM xx.xxx.x.xxx 49343 Requested GET /
2012-07-24 1:48:58 AM xx.xxx.x.xxx 51427 Login:  /
2012-07-24 2:08:52 AM xx.xxx.x.xxx 49553 Requested GET /
2012-07-24 3:00:31 AM xx.xxx.x.xxx 50333 Requested GET /
2012-07-24 11:42:17 AM xx.xxx.x.xxx 49312 Requested GET /

Code: [Select]
[unauthorized]
{.add to log|Login: %user% / %password%.}

[at 0:00]
{.stop server.}
{.add to log|Server Stopped.}
[at 0:30]
{.start server.}
{.add to log|Server Started.}

The extra entries are for debugging, I had the syntax wrong at first and just haven't removed them yet.
« Last Edit: July 24, 2012, 10:49:03 AM by woodfold »

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12844
    • View Profile
Re: server stops accepting connections
« Reply #1 on: July 29, 2012, 05:36:20 AM »
interesting!
the text formatting for the timestamp is actually discarding the time because it's perfectly 0:00, and it thinks we are just wasting zeroes :D (digits of precision, too long to explain it better).

Anyway, since this only happens in such case, i don't think it's a big problem.
To avoid it, just move your event at 0:01.

I wonder why you stop the service for 30 minutes, anyway. :)

Offline woodfold

  • Occasional poster
  • *
  • Posts: 1
    • View Profile
Re: server stops accepting connections
« Reply #2 on: July 29, 2012, 09:00:23 AM »
As a work-around I had changed it to 11:59, but thought you should know. Threw my log processing for a loop.

As to why, I do some other processing which takes progressively longer as the month goes on, so I wanted users to get used to a set amount of downtime. Cuts down on the whinging.  ;)