Author Topic: RAWR 0.1.2 - Search only finds files, but no folders?  (Read 2127 times)

0 Members and 1 Guest are viewing this topic.

Offline ladiko

  • Occasional poster
  • *
  • Posts: 75
    • View Profile
RAWR 0.1.2 - Search only finds files, but no folders?
« on: January 31, 2010, 04:13:39 PM »
if i search for abba, the following url is generated: http://localhost/Musik/?search=abba but this only lists the files with "abba" in the name, but not the folders. if i select extended search and select to only find folders, the url is http://localhost/Musik/?folders-filter=*abba*&recursive&files-filter=\ and the result list is empty.

why?

Offline TSG

  • Operator
  • Tireless poster
  • *****
  • Posts: 1934
    • View Profile
    • RAWR-Designs
Re: RAWR 0.1.2 - Search only finds files, but no folders?
« Reply #1 on: February 01, 2010, 04:03:33 AM »
Advanced search filters out either folders or files, or neither. The options are all there from memory.  That search you posted is looking for folders with the name 'abba' and filtering out files from the results.

Offline ladiko

  • Occasional poster
  • *
  • Posts: 75
    • View Profile
Re: RAWR 0.1.2 - Search only finds files, but no folders?
« Reply #2 on: February 01, 2010, 07:57:49 AM »
Yes, that is how i understand it, but in the target folder, I have folders like "Abba - Greatest Hits" and files like "Abba - Waterloo.mp3", so it always should list something, but it ignores folders. If i use "search files and folders" in rawr-template, it lists files. If i search for files, it lists files. If i search for folders, it lists nothing. Now I would like to find out, why it doesn't list folders.

Offline Mars

  • Operator
  • Tireless poster
  • *****
  • Posts: 1878
    • View Profile
Re: RAWR 0.1.2 - Search only finds files, but no folders?
« Reply #3 on: February 01, 2010, 08:56:49 AM »
use the default template from rejetto to verify if you have the same problems, and report what append.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: RAWR 0.1.2 - Search only finds files, but no folders?
« Reply #4 on: February 01, 2010, 05:44:38 PM »
i tested your case and it's working here.
is it solved now?
does it happen only with abba?

Offline ladiko

  • Occasional poster
  • *
  • Posts: 75
    • View Profile
Re: RAWR 0.1.2 - Search only finds files, but no folders?
« Reply #5 on: February 01, 2010, 10:31:31 PM »
the problem is, that i activated the option "auto-hide empty folders" for the folder containing the files and folders.

to test a little bit, i created a new real folder called "test", with following content:
h**p://localhost/test/Abba - Dancing Queen.mp3
h**p://localhost/test/Abba - Forever Gold/01 - Honey Honey.mp3

if i use the search, both are listed. now i activated "auto-hide empty folders" and refreshed the search and the folder disappears. now i added a file:

h**p://localhost/test/Abba - Dancing Queen.mp3
h**p://localhost/test/Abba - Forever Gold/01 - Honey Honey.mp3
h**p://localhost/test/Abba - Forever Gold/Abba - Fernando.mp3

and i refreshed the search, while the "auto-hide empty folders" option is activated and two files and the folder was listed.

conclusion:
when "auto-hide empty folders" is activated, a search only lists a folder if there is also a file in this folder, which matches the search. is it a wanted behaviour?
« Last Edit: February 01, 2010, 10:46:25 PM by ladiko »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: RAWR 0.1.2 - Search only finds files, but no folders?
« Reply #6 on: February 02, 2010, 05:36:55 PM »
well, this may even be correct, but i understand perfectly it's hard for the user to expect such result.
so, any good solution should be applied.
at the moment, the best thing i come with is "ignore the auto-hide option when a file-filter is used.
this is not perfect IMO, but acceptable, and nearer to what the user may expect.

unless a better suggestion comes, you'll find this change in build #254.

this is definitely not related to the template, so it's now moved to another board.