Author Topic: Speed Limit for single address doesn't work?  (Read 1210 times)

0 Members and 1 Guest are viewing this topic.

Offline Aveyer

  • Occasional poster
  • *
  • Posts: 3
    • View Profile
Speed Limit for single address doesn't work?
« on: December 27, 2009, 02:32:08 AM »
Hi, love HFS, really fast compared to others (maxes 100mbit ethernet connection). I'm trying to limit the speed per IP address but speed limit for single address doesn't work. Even with only 1 client(1 IP) downloading, that client is getting full speed, only the speed limit function works but that's a cap on the total speed. I'm using 2.3 Beta Build 250.

Thanks.
« Last Edit: December 27, 2009, 02:34:43 AM by Aveyer »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: Speed Limit for single address doesn't work?
« Reply #1 on: January 05, 2010, 10:57:55 PM »
sorry for the late reply, and welcome.

so, if you set this limit to 100, then when you try to download locally (same computer), it goes over the limit?
i just tried and it's working fine here.

Offline Aveyer

  • Occasional poster
  • *
  • Posts: 3
    • View Profile
Re: Speed Limit for single address doesn't work?
« Reply #2 on: January 07, 2010, 05:00:58 PM »
I've tried it from the same computer and other computers, it just never works. There are other threads about it not working too, there must be a bug with it somewhere.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: Speed Limit for single address doesn't work?
« Reply #3 on: January 18, 2010, 12:37:19 PM »
i've made some more tests and found the problem appears to be limited to dowloading folder archives.
indeed i was able to reproduce the problem, fixed a thing that was broken, and now it seems to be finally fixed. (in next release)

thank you for reporting

Offline Aveyer

  • Occasional poster
  • *
  • Posts: 3
    • View Profile
Re: Speed Limit for single address doesn't work?
« Reply #4 on: January 18, 2010, 06:51:23 PM »
Thanks for fixing, looking forward to the next beta  :).